CecoPRO Windows XP Operating System Conflict

CecoPRO Windows XP Operating System Conflict

Please check your operating system version.  In order to improve software installation performance of CecoPRO, Windows XP  will not be supported past December 31st, 2016. Windows 7, 8, 8.1, and 10 are supported as valid operating systems for CecoPRO.

Tags: